Switching tablets to another truck takes some time.

Incident Report for ICEcorp

Resolved

Works as intended. If you need a faster update, contact us and we'll manually clear the cache.
Posted Mar 05, 2025 - 12:30 CET

Identified

When you switch a tablet from one truck to another, it takes up to 1 hour to show the changes on the tablet. We're working on speeding this up.
Posted Mar 05, 2025 - 12:21 CET
This incident affected: ICEtruck (ICEtruck).